Welcome! Please use the navigational links on your left to explore our website.

Company Logo Shop Now
   Allis Chalmers Case Farmall IH Ford 8N,9N,2N Ford
   Ferguson John Deere Massey Ferguson Minn. Moline Oliver
 
Marketplace
Classified Ads
Photo Ads
Tractor Parts

Community
Discussion Forums
Project Journals
Tractor Town
Your Stories
Show & Pull Guide
Events Calendar
Hauling Schedule

Galleries
Tractor Photos
Implement Photos
Vintage Photos
Help Identify
Parts & Pieces
Stuck & Troubled
Vintage Ads
Community Album
Photo Ad Archives

Research & Info
Articles
Tractor Registry
Tip of the Day
Safety Cartoons
Tractor Values
Serial Numbers
Tune-Up Guide
Paint Codes
List Prices
Production Nbrs
Tune-Up Specs
Torque Values
3-Point Specs
Glossary

Miscellaneous
Tractor Games
Just For Kids
Virtual Show
Museum Guide
Memorial Page
Feedback Form

Yesterday's Tractors Facebook Page

Related Sites
Tractor Shed
TractorLinks.com
Ford 8N/9N Club
Today's Tractors
Garden Tractors
Kountry Life
  
John Deere Tractors Discussion Forum
:

john deere 2640 no hydraulics when resarting hot

Welcome Guest, Log in or Register
Author  [Modern View]
cowman79

07-08-2014 14:49:36




Report to Moderator

I have a 1979 2640 and sometimes when I have been running the tractor for a while and shut the tractor off for a little while and restart it I have no hydraulic pressure. At start up I have pressure but only for a few seconds then I loose the steering, three point, and the remotes. After about thirty seconds or so I get pressure back and never have another problem with the hydraulics. When first starting the tractor cold the hydraulics work as they are supposed to. A little history on the tractor When I bought it 6 months ago it had just had the charge pump replaced and new brakes. I have drained the oil, replaced the filter and cleaned the screen. The screen was relatively clean but the was some material in the old fluid. almost a metallic haze. Not sure if this was remaining debris from the previous owners repairs. I am not sure what I need to check at this time.

[Log in to Reply]   [No Email]
cowman79

07-08-2014 17:56:35




Report to Moderator
 Re: john deere 2640 no hydraulics when resarting hot in reply to cowman79, 07-08-2014 14:49:36  
[quote="D-"](quoted from post at 18:22:59 07/08/14) Metallic is from worn out brakes. A maqgnet in the screen will help.

Check valve is probably laying in a drain pan somewhere.[/quote

]

I was thinking the metallic was from the previous brakes coming apart. Where would this check valve be located. Also it seems to me like when the oil is hot is all drain back to the sump. Is this even possible.

[Log in to Reply]  [No Email]
D-

07-08-2014 19:23:46




Report to Moderator
 Re: john deere 2640 no hydraulics when resarting hot in reply to cowman79, 07-08-2014 17:56:35  
Hydraulic lines out of lower right front of tran to hyd pump.
Tx Jim will probably help you w/part pics.



[Log in to Reply]  [No Email]
Tx Jim

07-09-2014 04:04:14




Report to Moderator
 Re: john deere 2640 no hydraulics when resarting hot in reply to D-, 07-08-2014 19:23:46  
Check valve that D- referred to is parts keys 40-42(2nd photo). I think check valve isn't the hyd problem as check valve is to prevent hyd oil drain back during extended non-running periods of time.
I think your tractors hyd problem is a worn/pitted stroke control valve(parts key 42 & 43 1st photo) seat in frt hyd pump caused by the tiny metal particles.

third party image

third party image
This post was edited by Tx Jim at 04:06:00 07/09/14.

[Log in to Reply]  [No Email]
cowman79

07-09-2014 04:30:23




Report to Moderator
 Re: john deere 2640 no hydraulics when resarting hot in reply to Tx Jim, 07-09-2014 04:04:14  
Quoting Removed, click Modern View to see

Can this be removed and check easily.



[Log in to Reply]  [No Email]
Tx Jim

07-09-2014 06:52:12




Report to Moderator
 Re: john deere 2640 no hydraulics when resarting hot in reply to cowman79, 07-09-2014 04:30:23  
No not very easy to access as SC valve seat has to be driven out.



[Log in to Reply]  [No Email]
D-

07-08-2014 15:22:59




Report to Moderator
 Re: john deere 2640 no hydraulics when resarting hot in reply to cowman79, 07-08-2014 14:49:36  
Metallic is from worn out brakes. A maqgnet in the screen will help.
Check valve is probably laying in a drain pan somewhere.



[Log in to Reply]  [No Email]
[Options]  [Printer Friendly]  [Posting Help]  [Return to Forum]   [Log in to Reply]

Hop to:


TRACTOR PARTS TRACTOR MANUALS
Fast Shipping!  Most of our stocked parts ship within 24 hours (M-Th). We have the parts you need to repair your tractor - the right parts. Our fast shipping, low prices and years of research make us your best choice when you need parts. Shop Online Today. [ About Us ]

Home  |  Forums


Copyright © 1997-2019 Yesterday's Tractor Co.

All Rights Reserved. Reproduction of any part of this website, including design and content, without written permission is strictly prohibited. Trade Marks and Trade Names contained and used in this Website are those of others, and are used in this Website in a descriptive sense to refer to the products of others. Use of this Web site constitutes acceptance of our User Agreement and Privacy Policy

TRADEMARK DISCLAIMER: Tradenames and Trademarks referred to within Yesterday's Tractor Co. products and within the Yesterday's Tractor Co. websites are the property of their respective trademark holders. None of these trademark holders are affiliated with Yesterday's Tractor Co., our products, or our website nor are we sponsored by them. John Deere and its logos are the registered trademarks of the John Deere Corporation. Agco, Agco Allis, White, Massey Ferguson and their logos are the registered trademarks of AGCO Corporation. Case, Case-IH, Farmall, International Harvester, New Holland and their logos are registered trademarks of CNH Global N.V.

Yesterday's Tractors - Antique Tractor Headquarters

Website Accessibility Policy