Welcome! Please use the navigational links on your left to explore our website.

Company Logo Shop Now
   Allis Chalmers Case Farmall IH Ford 8N,9N,2N Ford
   Ferguson John Deere Massey Ferguson Minn. Moline Oliver
 
Marketplace
Classified Ads
Photo Ads
Tractor Parts

Community
Discussion Forums
Project Journals
Tractor Town
Your Stories
Show & Pull Guide
Events Calendar
Hauling Schedule

Galleries
Tractor Photos
Implement Photos
Vintage Photos
Help Identify
Parts & Pieces
Stuck & Troubled
Vintage Ads
Community Album
Photo Ad Archives

Research & Info
Articles
Tractor Registry
Tip of the Day
Safety Cartoons
Tractor Values
Serial Numbers
Tune-Up Guide
Paint Codes
List Prices
Production Nbrs
Tune-Up Specs
Torque Values
3-Point Specs
Glossary

Miscellaneous
Tractor Games
Just For Kids
Virtual Show
Museum Guide
Memorial Page
Feedback Form

Yesterday's Tractors Facebook Page

Related Sites
Tractor Shed
TractorLinks.com
Ford 8N/9N Club
Today's Tractors
Garden Tractors
Kountry Life
  
Case Tractors Discussion Forum
:

Speedo not working on Case 841

Welcome Guest, Log in or Register
Author  [Modern View]
farmerhr

12-23-2019 21:15:06




Report to Moderator

The speedo on my Case 841 does not work. I have taken the speedo head off the tractor and it seems to work with a short piece of cable. Tach works fine. Cable seems to go into the head alright.
Can anyone suggest how I should analyze the problem further ?
Also, any thoughts on what the most likely failure might be ?
Thank you in advance for any help that you can give me.
This site and the people here are absolutely wonderful !

[Log in to Reply]   [No Email]
farmerhr

12-24-2019 23:52:36




Report to Moderator
 Re: Speedo not working on Case 841 in reply to farmerhr, 12-23-2019 21:15:06  
Thank you for your reply. I appreciate your help.



[Log in to Reply]  [No Email]
kenbob

12-24-2019 07:10:48




Report to Moderator
 Re: Speedo not working on Case 841 in reply to farmerhr, 12-23-2019 21:15:06  
Don't know if they are similar, but i had the same problem. Seemed like everything should work. I had a new cable from John Saeli. Seems like the difference between working and not was about 1/4". I guess that sheathing has a little stretch in it. I adjusted the route of the cable to make sure it had the shortest route to the speedo. It has worked fine since.



[Log in to Reply]  [No Email]
[Options]  [Printer Friendly]  [Posting Help]  [Return to Forum]   [Log in to Reply]

Hop to:


TRACTOR PARTS TRACTOR MANUALS
Fast Shipping!  Most of our stocked parts ship within 24 hours (M-Th). We have the parts you need to repair your tractor - the right parts. Our fast shipping, low prices and years of research make us your best choice when you need parts. Shop Online Today. [ About Us ]

Home  |  Forums


Copyright © 1997-2019 Yesterday's Tractor Co.

All Rights Reserved. Reproduction of any part of this website, including design and content, without written permission is strictly prohibited. Trade Marks and Trade Names contained and used in this Website are those of others, and are used in this Website in a descriptive sense to refer to the products of others. Use of this Web site constitutes acceptance of our User Agreement and Privacy Policy

TRADEMARK DISCLAIMER: Tradenames and Trademarks referred to within Yesterday's Tractor Co. products and within the Yesterday's Tractor Co. websites are the property of their respective trademark holders. None of these trademark holders are affiliated with Yesterday's Tractor Co., our products, or our website nor are we sponsored by them. John Deere and its logos are the registered trademarks of the John Deere Corporation. Agco, Agco Allis, White, Massey Ferguson and their logos are the registered trademarks of AGCO Corporation. Case, Case-IH, Farmall, International Harvester, New Holland and their logos are registered trademarks of CNH Global N.V.

Yesterday's Tractors - Antique Tractor Headquarters

Website Accessibility Policy