Yesterday's Tractor Co. Tractor Parts for All Brands
Click Here or call 800-853-2651 
   Allis Chalmers Case Farmall IH Ford 8N,9N,2N Ford
   Ferguson John Deere Massey Ferguson Minn. Moline Oliver
 
Marketplace
Classified Ads
Photo Ads

Community
Discussion Forums
Project Journals
Tractor Town
Your Stories
Show & Pull Guide
Events Calendar
Hauling Schedule

Galleries
Tractor Photos
Implement Photos
Vintage Photos
Help Identify
Parts & Pieces
Stuck & Troubled
Vintage Ads
Community Album
Photo Ad Archives

Research & Info
Articles
Tractor Registry
Tip of the Day
Safety Cartoons
Tractor Values
Serial Numbers
Tune-Up Guide
Paint Codes
List Prices
Production Nbrs
Tune-Up Specs
Torque Values
3-Point Specs
Glossary

Miscellaneous
Tractor Games
Just For Kids
Virtual Show
Museum Guide
Memorial Page
Feedback Form

Yesterday's Tractors Facebook Page

Related Sites
Tractor Shed
TractorLinks.com
Ford 8N/9N Club
Today's Tractors
Garden Tractors
Classic Trucks
Kountry Life
Enter your email address to receive our newsletter!

subscribe
unsubscribe
  
John Deere Tractors Discussion Forum
Show Parts for Model:

4020 lost all hydraulics

Welcome Guest, Log in or Register
Author  [Modern View]
Chuck Hebert

01-14-2013 20:22:56
174.124.85.41



Report to Moderator

1965 4020 with powershift. The hydraulics has been weak for some time. As the tractor warmed up the 3pt and hydraulic cylinders would chatter and move slow. All hydraulics have gone out now, brakes, steering,3pt,trans, will get a little response if running for a bit, but will go out shortly after you use it. Is it the main pump.




[Log in to Reply]   [No Email]
Tx Jim

01-15-2013 04:08:52
67.142.163.22



Report to Moderator
 Re: 4020 lost all hydraulics in reply to rockyridgefarm, 01-14-2013 20:22:56  
I'd suggest changing hyd filters,cleaning sump screen and then checking trans pump and main hyd pump pressures. It's possible damper clutch stripped out.



[Log in to Reply]  [No Email]
4020_1966

01-14-2013 22:29:49
184.63.16.107



Report to Moderator
 Re: 4020 lost all hydraulics in reply to Chuck Hebert, 01-14-2013 20:22:56  
It sounds like your transmission lift pump is dead. It is not sending any oil to the main pump.



[Log in to Reply]  [No Email]
[Options]  [Printer Friendly]  [Posting Help]  [Return to Forum]   [Log in to Reply]

Hop to:

TRACTOR   PARTS TRACTOR   MANUALS
Same-Day Shipping! Most of our stocked parts ship the same day you order (M-F).  Expedited shipping available, just call!  Most prices for parts and manuals are below our competitors.  Compare our super low shipping rates!  We have the parts you need to repair your tractor.  We are a Company you can trust and have generous return policies!   Shop Online Today or call our friendly sales staff toll free (800) 853-2651. [ More Info ]

Home  |  Forums


Copyright © 1997-2014 Yesterday's Tractor Co.

All Rights Reserved. Reproduction of any part of this website, including design and content, without written permission is strictly prohibited. Trade Marks and Trade Names contained and used in this Website are those of others, and are used in this Website in a descriptive sense to refer to the products of others. Use of this Web site constitutes acceptance of our User Agreement and Privacy Policy

TRADEMARK DISCLAIMER: Tradenames and Trademarks referred to within Yesterday's Tractor Co. products and within the Yesterday's Tractor Co. websites are the property of their respective trademark holders. None of these trademark holders are affiliated with Yesterday's Tractor Co., our products, or our website nor are we sponsored by them. John Deere and its logos are the registered trademarks of the John Deere Corporation. Agco, Agco Allis, White, Massey Ferguson and their logos are the registered trademarks of AGCO Corporation. Case, Case-IH, Farmall, International Harvester, New Holland and their logos are registered trademarks of CNH Global N.V.

Yesterday's Tractors - Antique Tractor Headquarters